ID Asterisk

Suara tidak terdengar dari PSTN ke SIP


(Intan Mahardwiani) #1

Halo,

Mohon bantuannya ya,
Saya mengkonfigurasi dengan topologi seperti ini

WAN(IP Publik) <> Router Mikrotik (NAT) <> IP PBX Asterisk <> ATA SPA 3102 <> PSTN

Ketika saya dial dari nomor SIP ke PSTN/GSM, berhasil connect walaupun ringing di PSTN/GSM agak lama.
Ketika saya berbicara dari handset nomor SIP ke PSTN/GSM, lawan bicara saya dapat mendengarkan suara saya, yang menjadi masalah ketika lawan bicara saya yang berada di nomor PSTN/GSM berbicara, saya tidak dapat mendengarkan suaranya.

Pada ATA, bagian NAT sudah saya NAT mapping enable-kan, dan pada Asterisk bagian [general] sudah saya tambahkan externip, localnet untuk konfigurasi NAT nya…

Kenapa yaa? Anyone help?
Apalagi yang harus di konfigurasi di bagian PSTN Line pada ATA?

Terimakasih sekali


(ASK) Bagaimana Cara Brikerbox dapat di akses menggunkanan IP Publik Mikrotik
Masalah One way audio
X-lite tidak keluar suara
X-lite tidak keluar suara
[ASK] Asterisk di belakang router (NAT) - SIP Telkom Unmonitoring
(Anton Raharja) #2

SIP softphone nya disebelah mana ?

anton


(Intan Mahardwiani) #3

Oiya maaf pak,
Jadi begini topologinya

                   WAN (IP public)
                               |
                Router Mikrotik (NAT) 
                               |
  PSTN - ATA - Switch - client (using Zoiper/3cx phone)
                               |
                     IP PBX Asterisk

Mohon bantuannya pak.
Terimakasih


(Anton Raharja) #4

Halo,

Kalo seperti ini tidak ada masalah nat dan tidak perlu pakai externip

Zoiper, ATA dan Asterisk nya 1 LAN ?

anton


(Intan Mahardwiani) #5

Iya pak satu network LAN…
Agar bisa di akses dr jaringan Internet saya gunakan NAT pak, karena itu saya pakai externip di [general] di sip.conf nya pak…
Bagaimana ya pak?


(Anton Raharja) #6

coba paste bagian externip nya (tmsk localnet), pastikan LAN anda masuk dalam localnet itu

anton


(Intan Mahardwiani) #7

Begini pak konfigurasi di SIP.conf saya

[general]
externip=219.xx.xxx.xxx
localnet=10.10.10.0/255.255.255.0
bindport=5060
bindaddr=0.0.0.0
tcpbindaddr=0.0.0.0
udpbindaddr=0.0.0.0
nat=yes
disallow=all
allow=alaw
allow=ulaw

[900]
nat=yes
qualify=yes
host=dynamic
dtmfmode=rfc2833
secret=xxxxx
disallow=all
allow=ulaw
allow=alaw
type=friend
username=900

Terimakasih pak


(Anton Raharja) #8

dan LAN yang mencakup zoiper, ata dan asterisk berada pada cakupan localnet ? 10.10.10.0/255.255.255.0 ?

anton


(Intan Mahardwiani) #9

Iya pak ATA mencakup localnet, kecuali Zoiper/3cx phone (softphone dari Android/Laptop) yang connect ke Internet, itu IP nya diluar localnet pak…

Apakah di ATA harus ditambah konfigurasinya lagi ya pak?

Soalnya, kalau saya connect via jaringan local(private) suara dari sip<>pstn OK baik pak…

Terimakasih paj


(Anton Raharja) #10

ok, jadi Zoiper ini bisa dalam LAN atau dari Internet, kalo dari LAN maka semua sudah OK, tapi kalo dari Internet baru ada masalah one-way audio, yaitu audio hanya dari SIP ke PSTN (Zoiper ke ATA).

Coba buat layanan di internal Asterisk nya, misal echo(), lalu dial nomor echo nya.

Kalo tidak bisa maka coba dial dari Zoiper di Internet ke Zoiper yang berada di LAN.

anton


(Intan Mahardwiani) #11

Maaf pak ada sedikit revisi, one-way audio nya itu dari PSTN ke SIP (ATA ke Zoiper). Kalo dr SIP ke PSTN sudah Ok,pak…

Baik akan saya coba dulu test echo nya, nanti hasilnya akan saya post lagi ya pak.

Terimakasih pak


(Anton Raharja) #12

ya, jalankan 2 tets itu aja deh ya kalo bisa:

  1. echo test
  2. zoiper internet ke zoiper lan

sebelum bicara sip debug, setting di ata dll, malasnya setting di ata itu kan namanya alat beda2 menunya, jadi ngga hapal

@asoka hafal mungkin menu di ata yang terkait masalah spt ini

anton


(Asoka Wardhana) #13

Halo,

Bu Intan bisa tolong paste konfigurasi nat pada mikrotiknya ?

Bisa jadi port RTP nya tidak terkirim ke IP Internet zoiper, karena konfigurasi src nat dari IP Private ATA ke IP Internet zoipernya via IP Public di mikrotik kurang tepat.


(Intan Mahardwiani) #14

Dear @asoka

Berikut konfigurasinya,

  1. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=5060 protocol=tcp dst-port=5060

  2. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=5061 protocol=tcp dst-port=5061

  3. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=3479 protocol=tcp dst-port=3479

  4. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=5000 protocol=tcp dst-port=5000

  5. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=4569 protocol=tcp dst-port=4569

  6. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=4520 protocol=tcp dst-port=4520

  7. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=3478 protocol=tcp dst-port=3478

  8. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=5060 protocol=tcp dst-port=5060

  9. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=5066 protocol=tcp dst-port=5066

  10. Chain=dstnat dst address = 219.xxx.xx.xxx action=dst-nat to- addresses=10.1010.6 to-ports=10000-20000 protocol=tcp dst-port=10000-20000

Apakah port yang saya buka ada yang kurang atau yang salah?
Terimakasih ya…


(Intan Mahardwiani) #15

Maaf, itu harusnya dst-nat to- addresses=10.10.10.6


(Anton Raharja) #16

Halo,

RTP seharusnya UDP nya ya, yang 10000-20000

anton


(Intan Mahardwiani) #17

Dear pak Anton, dan pak @asoka

Dari hasil searching juga, saya sudah rubah lagi untuk port nya menjadi

5060 = udp
5061 = udp
5066 = udp
5070 = udp
5000 = udp
4569 = udp
4520 = udp
3478 = udp
3479 = udp
10000-20000 = udp

Apakah masih ada yang kurang or salah? Mohon di koreksi.

Terimakasih yaa


(Asoka Wardhana) #18

Halo,

Itu baru dst-nat, src nat untuk traffic yang dari ip 10.10.10.6 ke ip 219.xxx.xxx.xxx nya belum, makanya jadi one way.

Untuk cobanya biar simple gini, full nat semua port aja dulu tidak usah pakai port (config nat yang sekarang disable saja dulu), setelah berhasil full nat semua port baru mulai config per port saja yang di nat.

chain=dstnat dst-address=219.xxx.xxx.xxx action=dst-nat to-addresses=10.10.10.6

chain=srcnat src-address=10.10.10.6 action=src-nat to-addresses=219.xxx.xxx.xx


(Intan Mahardwiani) #19

Dear Pak @asoka,

Baik akan saya coba.
Hasil lebih lanjut nya akan saya post disini kemudian.

Terimakasih sarannya pak…


(Intan Mahardwiani) #20

Dear pak @asoka,

saya sudah menambahkan konfigurasi dstnat dan srcnat sesuai saran bapak.
tetapi yang terjadi adalah, konfigurasi dstnat port 5060 dan 5061 yang saya konfigurasi tidak terlewati packet data. kemudian, softphone pun gagal teregistrasi. ketika saya disable konfigurasi untuk beberapa port yang sebelumnya saya konfig, soft phone pun tidak berhasil ter register.

konfigurasi registrasi softphone saya sebagai berikut :
userID : 900
password : xxxxxxx
host : 219.xxx.xxx.xxx:5060

mohon pencerahannya pak…