[SOLVED] Briker 2.1 Support Account not part of Sudoer


(dpsguard) #1

Hi, I have just downloaded and installed Briker on a VM. I can console in using default support account with password of Briker and when I try to change default IP address, I need to sudo su -, and then supplying this password, I get error that support account is not part of the sudoers file.

Please advise if I need to create / add a root password (regular password recovery procedure for root) and then use that to edit any configuration files or make support account part of sudoer file?

Thanks so much.

PS: I first posted this by error under Asterisk category, because I don’t understand bahasa indonesia.


(dpsguard) #2

Hello everyone,

I can login to webmin / server manager using support / Briker and I can then change IP address. That works. But I can then also change the gateway, but while it shows on webmin screen and I can hit apply config or restart networking service or even reboot or shutdown and restart machine, gateway does not get installed in machine. Consequently, I cannot ping it or ping out from machine anywhere outside its own subnet. IP route or netstat -nr or route -nr don’t show any gateway. I am sure some of you would have run into the same issues. what did you do to resolve this issue?

And I am hoping author of the code may read my posts and advise.

Thanks


(dpsguard) #3

Folks, I have resolved the issue.

I have been reading the quick start guide and admin manual, but those are bit old. So instead of doing sudo su -, I simply did su - and it then puts me in direct root shell and I was then able to vi the /etc/network/interfaces file for the correct gateway. Then tried to restart the network service using systemctl restart network and that did not work. I then did a reboot and I can now ping across the subnets.

Thanks and very best,